Автор Тема: [РЕШЕНО] Redmine: (wrong argument (NilClass)! (Expected kind of OpenSSL::SSL::SSLContext)  (Прочитано 1602 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Gib_adm

  • Постоялец
  • ***
  • Сообщений: 122
  • Рейтинг: 2
  • Пол: Мужской
    • Просмотр профиля
  • Откуда: Нерезиновая
Доброго времени суток, Коллеги.

Имеется вопрос к знатокам ruby и redmine :
ОС CentOS 6.7 64
Environment:
  Redmine version                          2.3.1.stable
  Ruby version                             1.8.7 (x86_64-linux)
  Rails version                            3.2.13

При тестовой отправки сообщения выдает:
Во время отправки письма произошла ошибка (wrong argument (NilClass)! (Expected kind of OpenSSL::SSL::SSLContext))

Конфиг configuration.yml :

production:
  delivery_method: :smtp
  smtp_settings:
    address: "smtp.mail.ru"
    enable_starttls_auto: true
    port: 587
    domain: "smtp.mail.ru"
    authentication: :plain
    user_name: "redmine@domain.com"
    password: "******"

Пробовал еще:
production:
  delivery_method: :smtp
  smtp_settings:
    address: "smtp.mail.ru"
    port: 25
    domain: "smtp.mail.ru"
    authentication: login
    user_name: "redmine@domain.com"
    password: "******"

В обоих случаях результат один. 

Есть мысли?
« Последнее редактирование: 25 Января 2016, 21:07:14 от Gib_adm »

Оффлайн VanDyke

  • Модератор
  • Ветеран
  • *****
  • Сообщений: 1800
  • Рейтинг: 73
  • Пол: Мужской
  • Network Warrior
    • Просмотр профиля
  • Откуда: Destination network unreachable
Redmine: (wrong argument (NilClass)! (Expected kind of OpenSSL::SSL::SSLContext)
« Ответ #1 : 25 Января 2016, 20:09:53 »
Gib_adm, ошибка описана здесь
https://www.redmine.org/issues/13698
если не надо tls - его можно попробовать отключить
 enable_starttls_auto: false
иначе пробовать с  2.5.3 версией mail
Not as ultimate as 42, but pretty close...

Оффлайн Gib_adm

  • Постоялец
  • ***
  • Сообщений: 122
  • Рейтинг: 2
  • Пол: Мужской
    • Просмотр профиля
  • Откуда: Нерезиновая
Redmine: (wrong argument (NilClass)! (Expected kind of OpenSSL::SSL::SSLContext)
« Ответ #2 : 25 Января 2016, 20:44:12 »
Попробовал поставить mail 2.5.3. Отвалился ruby. И похоже требует вернуть ему mail 2.5.4

Ruby on Rails application could not be started

Error message:
    Could not find mail-2.5.4 in any of the sources (Bundler::GemNotFound)
Exception class:
    PhusionPassenger::UnknownError

Оффлайн Gib_adm

  • Постоялец
  • ***
  • Сообщений: 122
  • Рейтинг: 2
  • Пол: Мужской
    • Просмотр профиля
  • Откуда: Нерезиновая
Как сказано в коментах, поправил Gemfile.lock на mail (2.5.3) и все взлетело.

Спасибо!