Автор Тема: [Решено] PPOE -> WiFI Router -> Windows 7 (не могу установить MTU)  (Прочитано 2757 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн diclofoss

  • Новичок
  • *
  • Сообщений: 2
  • Рейтинг: 0
    • Просмотр профиля
  • Откуда: yandex
Привет!
Московский провайдер Lanport поставляет в мою квартиру интернет.
Шнурок приходит в мой Wifi router Dlink DIR-320 далее инет раздается по квартире под средством WIFI
Инет работает нормально, но иногда некоторые файлы по FTP я не могу скачать или закачать.
Попробовал шнурок воткнуть в ноутбук - качаются.
Позвонил провайдеру, тот посоветовал мне выставить значение MTU 1448.
Я открыл настройки интернет соединения на роутере и выставил ему значение MTU=1448
После этого делаю:

C:\Program Files (x86)\Far2>netsh interface ipv4 show subinterfaces

MTU Состояние определения носителя Вх. байт Исх. байт Интерфейс
------ --------------- --------- --------- -------------
4294967295 1 0 26338 Loopback Pseudo-Interface 1
1500 1 9892421 1698747 Беспроводное сетевое соединение
1500 5 0 0 Подключение по локальной сети
1500 5 0 0 Сетевое подключение Bluetooth 2
1500 1 0 21703 VirtualBox Host-Only Network

Вижу что значение MTU у меня на ноутбуке слишком большое у беспроводного сетевого соединения
И действительно:

C:\Program Files (x86)\Far2>ping -f -l 1500 ya.ru

Обмен пакетами с ya.ru [93.158.134.3] с 1500 байтами данных:
Требуется фрагментация пакета, но установлен запрещающий флаг.

Путем перебора перебераю значение и получаю

C:\Program Files (x86)\Far2>ping -f -l 1419 ya.ru

Обмен пакетами с ya.ru [93.158.134.3] с 1419 байтами данных:
Ответ от 93.158.134.3: число байт=1419 время=10мс TTL=60

Далее делаю:
C:\Program Files (x86)\Far2>netsh interface ipv4 set subinterface "Беспроводное сетевое соединение" mtu=1419 store=persistent
ОК.
И после делаю снова:
C:\Program Files (x86)\Far2>ping -f -l 1419 ya.ru

Обмен пакетами с ya.ru [93.158.134.3] с 1419 байтами данных:
Требуется фрагментация пакета, но установлен запрещающий флаг.

Файлы как не качались так и не качаются.

Где я ошибся подскажите, пожалуйста?

Комментарий модератора Добавлено в название [Решено]
« Последнее редактирование: 06 Июня 2011, 07:30:01 от risc »

Оффлайн shs

  • Модератор
  • Ветеран
  • *****
  • Сообщений: 4398
  • Рейтинг: 89
    • Просмотр профиля
    • ShS's blog
  • Откуда: Default city
думаю, что на стороне windows можно было бы ничего не делать, т.к. windows умеет path mtu discovery

Что касается проблемы. Думаю, что проблема в устройстве d-link. У меня тоже d-link и те же симптомы:
при подключении компьютера напрямки к провайдеру - все работает, при подключении через d-link - наблюдаются проблемы.

Оффлайн diclofoss

  • Новичок
  • *
  • Сообщений: 2
  • Рейтинг: 0
    • Просмотр профиля
  • Откуда: yandex
Проблема решена.
Обнови прошивку девайса.
У меня стояла за 2008й год. Поставил самую свежую, добавился новый функционал + устрались многие проблемы

Оффлайн shs

  • Модератор
  • Ветеран
  • *****
  • Сообщений: 4398
  • Рейтинг: 89
    • Просмотр профиля
    • ShS's blog
  • Откуда: Default city
Проблема решена.
Обнови прошивку девайса.
У меня стояла за 2008й год. Поставил самую свежую, добавился новый функционал + устрались многие проблемы
Это замечательно, что вам помогло обновление Firmware. К сожалению, у меня это не работает. Уже попробывал даже dd-wrt новейшую залить (вместо родной) - эффект нулевой.